Install libstdc++-33.x86_64 module on linux

Spread the love
  1. root@rhel5-host ~]# yum install compat-libstdc++-33

If error coming like this

Error: failure: repodata/primary.xml.gz from public_ol6_latest: [Errno 256] No more mirrors to try.

Steps are to resolve

$ yum clean all

$ yum check-update

cd /etc/yum.repos.d

wget http://public-yum.oracle.com/public-yum-ol6.repo

yum repolist

 pm –import /usr/share/rhn/RPM-GPG-KEY

 rpm -q gpg-pubkey-ec551f03-4c2d256a

 After the updates are complete system might start throwing a CERT Error

 rhn-plugin: ERROR: can not find ULN CA file: /usr/share/rhn/RHNS-CA-CERT

========================================================================

 To resolve this, follow the below,

# cd /usr/share/rhn

 You will find the cert ULN-CA-CERT

 # vi /etc/sysconfig/rhn/up2date

 sslCACert=/usr/share/rhn/RHNS-CA-CERT

 In this line change RHNS-CA-CERT to ULN-CA-CERT

 Should be like this

 sslCACert=/usr/share/rhn/ULN-CA-CERT

 Now run

# yum info

Then,

yum.repos.d]# yum list compat-libstdc++-33

Installed Packages

compat-libstdc++-33.x86_64           3.2.3-69.el6             @local_ol6_latest

Available Packages

compat-libstdc++-33.i686             3.2.3-69.el6             local_ol6_latest

Leave a Reply

Your email address will not be published. Required fields are marked *